Opel Agila with electrical problems | Automotive diagnostics articles

18 Jul 2014 | Author: | Comments Off on Opel Agila with electrical problems | Automotive diagnostics articles
Opel Agila

Used equipment

Automotive ATS5004D 4 channel automotive with differential inputs

lead TP-C1812B low noise BNC to banana measuring lead, 3 m

Probe TP-BP85 thin and back probe

The Automotive ATS5004D is in this article referred to as automotive oscilloscope . as oscilloscope and as lab scope .

Problem

A 2006 Opel Agila was engine problems. The engine power, ran very badly idling and would not rev up higher 1600 rpm. The garage the following codes:

P0120 Position Sensor/Switch A Circuit

P0220 Throttle/Pedal Position B Circuit Malfunction

P1523 Closed Position Performance

Minimum Throttle Position Not

P0530 A/C Refrigerant Pressure Circuit Malfunction

The Engine Module (ECM) indicated with components that could have to do with problem (except for the A/C refrigerant sensor). The garage did not have a diagnosis oscilloscope, so they replacing components, hoping to the problem. They replaced the body, the throttle position the ECM and finally a part of the wiring None of these replacements any improvement.

In fact, after replacing the harness, the scanner could no communicate with the systems, appeared ….

Background

This Opel Agila has an controlled throttle. The accelerator has a position sensor that the Engine Control Module about the position of the pedal. The body contains an electro that positions the throttle Depending on the position of the accelerator the ECM drives the throttle plate

A Throttle Position Sensor the throttle plate position and that information back to the so it can verify the throttle plate For safety reasons, the throttle has two fully independent Throttle Sensors. The two sensors have an signal related to the throttle position, between 0V and +5V.

One sensor uses 0V for fully and +5V for fully open, the other is inverted: +5V for fully closed and 0V for open.

Measuring

The communication

The first thing to solve was the problem. The communication bus contains a signal (K-line) which is to +12 V when a scanner is This signal did however low (0 V). After systematically parts from the bus to locate a ECM or defective wiring, the search at the replaced wiring harness.

Not surprising, as replacing the wiring caused the communication to be …. one of the connectors of the harness was disconnected, the of the problem was found, see figure 1.

1: A bent connector pin

The bent pin to be a ground pin, touching the signal, causing all communication to After fixing the connector, all was back and codes could be again. It did however not solve the problems, it still ran badly and had no

The badly running engine

It that the engine was running on two cylinders. To find out why, a channel automotive oscilloscope was to the injectors and the ignition. Both strange signals, but the injectors focused on first.

Figure 2: of all 4 cylinders

Figure 2 shows the signals of all four cylinders, but 1 and 4 show no injection pulses. stopping and starting the engine new measurements could also proper pulses for cylinders 1 and 4 and pulses for cylinder 2 and 3. Defective or defective wiring cannot this, this had to be a problem at the unit side.

It could also happen when the throttle was increased, all would operate normally, but the plate would remain closed.

Opel Agila

The ignition system showed strange signals, see 3.

Figure 3: Strange ignition

This could of course be operation, but in the spark signals of 1 occasionally a very short was seen. When checking the plug for cylinder 1, the center appeared to be off-center. After the spark plug, the spark was but the engine kept running

Throttle adjustment

Since codes regarding the electrically throttle kept reappearing, the body was checked. It was noticed the throttle plate did not move, by the throttle position sensors remaining on fixed values. disconnecting the throttle and applying 12V to the that controls the plate, it that the throttle valve did and thus is functioning.

At some moments however, Throttle Position Sensor showed large fluctuations, the engine kept running at the speed, indicating that the plate did not move. This be a problem with the Throttle Sensors.

Figure 4: Fluctuations in TPS

Figure 4 shows the two Throttle Sensor signals intermittently to 0V. This could indicate a +5V problem, therefore the 5V supply of the ECM to the sensors was monitored. The 5V power stable during the intermittent ruling out the power supply for the

Since the throttle body was replaced, the only remaining cause would be a wiring

Cause and solution

When back probes were in the rear of the connector, to measure the signals, the problem appeared to be and the engine was running properly, no more error codes. the probes were removed the problem reappeared. Examination of the showed that several of the connector had insufficient contact resulting in a bad electrical connection.

Figure 5: A bad connector terminal

The were solved by fixing the terminals. The two TPS signals behave as seen in figure 6. Also and injection patterns were again.

Conclusion

What has the low contact pressure in the connector is not fully clear, perhaps a too probe was inserted in the terminal to the signal, damaging the terminal. back probes are available, can be inserted in the back of connectors, the terminal and the isolation, allowing to the terminals without causing any

Opel Agila
Opel Agila
Opel Agila
Opel Agila
Opel Agila
Tagged as:

Other articles of the category "Opel":

Twitter-news
Our partners
Follow us
Contact us
Our contacts

dima911@gmail.com

Born in the USSR

423360519

About this site

For all questions about advertising, please contact listed on the site.


Car Catalog with specifications, pictures, ratings, reviews and discusssions about cars